HaneCa

独り立ちへ向けた長い道

Macでnpmを実行できなくなった時の対処法

投稿日: 2018年3月11日

MacでHomebrewコマンドを使ってアップデートした際にnpmを実行すると次のようなエラーが発生して実行できなくなるようになりました。

Error: Cannot find module '../lib/utils/unsupported.js'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at /usr/local/lib/node_modules/npm/bin/npm-cli.js:19:21
    at Object.<anonymous> (/usr/local/lib/node_modules/npm/bin/npm-cli.js:92:3)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)

原因はよくわかりませんが、次のようにnpmだけを再インストールすると解決するようです。

まず、一旦、Node.jsをアンインストールします。

$ brew uninstall --force node

さらに、もし次のディレクトリがあれば、それも削除します。

$ sudo rm -rf /usr/local/lib/node_modules

次に再びNode.jsをインストールします。

$ brew install node

正しくインストールされたかを確認します。

$ node -v
v9.8.0
$ npm -v
5.6.0

 

“Macでnpmを実行できなくなった時の対処法” への1件のコメント

mac OSで”npm unsupported.jsが見つからない”と言われたときの対処法 – 株式会社シーポイントラボ | 浜松のシステム・RTK-GNSS開発 へ返信する コメントをキャンセル

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください