Pythonのダウングレード (Mac)

投稿者: | 2018年8月24日

Python 3.7を利用してTensorflowをインストール、実行していましたが、3.6から3.7に変わったことで様々なエラーが発生するようになったため、ダウングレードすることにしました。

その方法は、次のようにpyenvコマンドをbrewコマンドでインストールします。そして、pyenvコマンドを用いて、Python 3.6.6をインストールし、それをグローバルで利用するように設定するだけです。

インストール中にエラーが発生する場合の対処法

pyenvコマンドを使って、特定のバージョンのpythonをインストールしようとした場合、次のようなエラーが発生することがあります。

これは、zlibというライブラリが必要だがインストールされていないという意味だと思い、次のコマンドを実行してzlibをインストールしましたが、エラーは解決しませんでした。

調べてみると、Mojaveのxcode-selectの最新版にはmacOSX のヘッダファイルが入っていないことが原因のようで、次のコマンドを実行して、それをインストールする必要があるようです。

参考サイト

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です