HaneCa

独り立ちへ向けた長い道

Terraform で Azure API Management を作成したときのエラー

投稿日: 2021年1月17日
Photo by AltumCode on Unsplash

Terraformを使って、Azure API Managementを作成しようとしたとき、次のようなエラーが出ました。

原因はTerraformのバージョンが古く、2.42.0以降でなければ、API ManagementのConsumptionプランの作成に対応していないとのことでした。

そこで、次のようにTerraformのAzureプロバイダのバージョンを指定することで解決しました。

さらに、バージョンを書き換えた場合、構成をアップグレードするため、次のコマンドを実行する必要があります。

参考サイト

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください